Synfig Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
OPEN  Bug report #686  -  Copy paste a skeleton layer (with more than one bone) do not work
Posted Oct 07, 2014 - updated Jan 05, 2019
action_vote_minus_faded.png
1
Votes
action_vote_plus_faded.png
Issue details
  • Type of issue
    Bug report
  • Status
     
    New
  • Assigned to
    Not assigned to anyone
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     djay
  • Owned by
    Not owned by anyone
  • Category
    Artwork construction
  • Resolution
    Not determined
  • Priority
    Not determined
  • Targetted for
    icon_milestones.png 1.0
  • Tags
    icon_customdatatype.png skeleton
  • Difficulty
    icon_customdatatype.png Not determined
Issue description
Copy and paste a skeleton layer do not work : at first look, we can think that all bones are not copied, but in fact they are, but child bones of pasted skeleton layer still have original skeleton has parent.

Skeleton A : Bone A1 + Bone A2 Copied to Skeleton B : Bone B1 + Bone B2

Bone B2's parent is Bone A1.
Steps to reproduce this issue
  • new canvas
  • new skeleton layer
  • add child bone
  • select skeleton (A) layer in layer panel
  • copy / paste
  • select pasted skeleton (B) in layer panel
  • move the parent bone (B1) origin
---> Only one bone is moved : where is B2 ???? ---> You can notice something strange with the bounding box. ---> In fact B2 is still linked to A1 !