Synfig Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #407  -  Navigator blinks when scrubbing the timeline
Posted Apr 26, 2013 - updated Jan 05, 2019
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     Carlos López
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Carlos López
  • Owned by
    Not owned by anyone
  • Time spent
    1 hour
  • Category
    Rendering
  • Resolution
    RESOLVED
  • Priority
    Must fix before next release
  • Targetted for
    icon_milestones.png 0.64.0
  • Tags
    icon_customdatatype.png navigator timeline scrubbing blink
  • Difficulty
    icon_customdatatype.png Not determined
Issue description
Scrubbing the timeline makes the navigator blinks (renders empty and then the correct content).

It is caused by a previous fix for the shadow layer that doesn't clean the previous render on the Navigator.
Steps to reproduce this issue
Nothing entered.

#3
Comment posted by
 Carlos López
Apr 26, 17:04
Removed the code from previous commit that clean the navigator surface before render and force the Shadow layer to clean its passed surface when it is rendered. This way the blinking doesn't happen and the shadow layer renders correctly on the navigator.

The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from New to Closed.
  • This issue's progression has been updated to 100 percent completed.
  • The resolution has been updated, from Not determined to RESOLVED.
  • Information about the user working on this issue has been changed, from Carlos López to Not being worked on.
  • Time spent on this issue, from No time spent to 1 hour.
#4
Comment posted by
 d_rylander
May 01, 21:29
Confirmed to be fixed in rev. 20130427.