Synfig Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #365  -  Development packages crash in Ubuntu 12.04 and Cairo render
Posted Apr 06, 2013 - updated Jan 05, 2019
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     Konstantin Dmitriev
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Carlos López
  • Owned by
    Not owned by anyone
  • Time spent
    2 weeks, 4 days, 24 hours
  • Category
    Crash
  • Resolution
    RESOLVED
  • Priority
    Must fix before next release
  • Targetted for
    icon_milestones.png 0.64.0
  • Tags
    icon_customdatatype.png crash cairo package dependence
  • Difficulty
    icon_customdatatype.png Not determined
Issue description
Development version of Synfig Studio (master branch commit 9e8d90db11009151ee370213e54b468638aae4e2), package created on Linux Mint 14 (equivalent to Ubuntu 12.10) crashes when any of the features that exists on Cairo >= 1.12.0 is used in Ubuntu 12.04 64 bits.

Looks like the synfig libraries aren't liked against the 1.12.* cairo version requested but it is using the cairo system libraries. So if the system sunning Synfig is doesn't have cairo >= 1.12.0 it doesn't find the proper symbol in the libraries and crash.

Steps to reproduce this issue
Download the package from here:

and install in Ubuntu 12.04 Create a layer (circle), group it -> crash


#2
Comment posted by
 Carlos López
Apr 06, 17:50
Running Ubuntu 12.04 I did:

  1. Clone the git repository: git clone https://github.com/synfig/synfig.git
  2. Moved to autobuild folder and run the build script: LANG=C sudo bash synfigstudio-linux-build.sh package
  3. After a while six packaged are created. It means that it is possible to build the Synfig code with the script.
  4.  I installed the corresponding package to the architecture (amd64 deb) without any complain from the installer.
  5. I run Synfig Studio create a circle layer and group it ==> crash


synfigstudio: symbol lookup error /opt/synfig/lib/libsynfig.so.0 undefined symbol: cairo_surface_create_similar_image

Also, I've opened synaptic and verify the installed files and the dependences:

Dependences: https://dl.dropbox.com/u/7125719/dependencies.png Files provided: https://dl.dropbox.com/u/7125719/installed_files

And there is no trace of cairo in the dependences or the installed files. So the conclusion is that the script compiles an links against the correct cairo library but it is not provided and so it crashes when a synbol only existing in cairo > 1.12 is used.
#4
Comment posted by
 Konstantin Dmitriev
Apr 25, 16:57
Should be fixed now

The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from New to Closed.
  • This issue's progression has been updated to 100 percent completed.
  • The resolution has been updated, from Not determined to RESOLVED.
  • Information about the user working on this issue has been changed, from Konstantin Dmitriev to Not being worked on.
  • Time spent on this issue, from No time spent to 2 weeks, 4 days, 24 hours.
#5
Comment posted by
 Dolf1988
Sep 09, 06:15
It's always annoying to find some software doesn't work with your Linux distribution. This happens because of differences in the software packages and repositories. In this case, we will be looking at Cairo render crashed, or developed packages failing to render images on Ubuntu 12.04 LTS. You need to visit here https://rubygarage.org/services/web-app-design-services and get more new skills for applications. If you are using Ubuntu 12.04 or Firefox 3.5, then it is highly recommended you install the development packages for Cairo and Grease Monkey. When I tried this, a browser crash occurred when the render function was done with Cairo.
#6
Comment posted by
 AnaTroe
Oct 15, 05:01
For several months, I have been working on a project that required rendering images using Cairo on Ubuntu 12.04. Cairo is a 2D and 3D graphics library, rendering engine, and toolkit developed by the Gnome team. Here you follow the cheating spouse text messages codes and get more new tricks for knowing about spouse cheating. In order to ensure that everything went smoothly, I installed a development version of Ubuntu with the same version of Cairo included in it. However, as soon as I installed Cairo and started rendering, it crashed every time I tried running the test program or even just starting any new application.
#7
Comment posted by
 Steff Coleman
Oct 28, 13:36
There wasn't much of use to me, the content here isn't informative. I will surely post a review about it, please follow this link. you will like the content here

#8
Comment posted by
 Cranswick
Nov 22, 11:33
Development packages crash in Ubuntu 12.04 and Cairo render, because the Cairo render package has errors in its dependencies. Here you check this briansclub and get more new ways for trading. I have recently discovered that the development packages crash in Ubuntu 12.04 when using Cairo renders with this library. This has caused me grief for about six hours now and I'm finally getting somewhere with fixing it.