Synfig Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #36  -  Sewed same color regions by its edge create thin lines
Posted Dec 14, 2012 - updated Jan 05, 2019
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Closed" and resolution "WON'T FIX".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
    Not assigned to anyone
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Imported User
  • Owned by
    Not owned by anyone
  • Category
    Not determined
  • Resolution
    WON'T FIX
  • Priority
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Tags
    icon_customdatatype.png Not determined
  • Difficulty
    icon_customdatatype.png Not determined
Issue description
genete:

Rendering with quality>0 the attached file produces a thin line in the sewed area. It doesn't matter what value you use to anti aliasing.

If you set the quality to be exactly 0 then the thin line disappears. But it would not render some layers (plant, blurs, etc.)

Also quality=0 and anti aliasing set to big values increases the render time a lot.

Using svn r1176
Steps to reproduce this issue
Nothing entered.

#2
Comment posted by
 Imported User
Dec 14, 16:50
A file was uploaded. aliasing.sifzicon_open_new.png This comment was attached:

Sample file to show the bug
#3
Comment posted by
 Imported User
Dec 14, 16:51
A file was uploaded. antialias.pngicon_open_new.png This comment was attached:

dooglus:

It doesn't matter what value you use to anti aliasing.


I think it does. If you turn off the 'antialiasing' checkbox in both 'left' and 'right' layers in your example then the thin line disappears.

It seems as if it's the antialiasing that causes the thin line. Could it be that 'left' and 'right' fit together perfectly, but that one of both of the layers is having a little background color added to it by the antialiasing?

See the attached screenshots, showing how the thin line looks with the 4 combinations of antialiasing on and off for the left and right layers. "left" means antialiasing is on only for the left layer, "both" means it's on for both.
#4
Comment posted by
 Konstantin Dmitriev
Dec 14, 16:54
This is not really a bug. Such behaviour is caused by the way how anti-aliasing works in the Synfig's rendering engine.

See ways to workaround here: http://wiki.synfig.org/wiki/Sewing_BLines#Removing_thin_line_bug

The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from New to Closed.
  • This issue's progression has been updated to 100 percent completed.
  • The resolution has been updated, from Not determined to WON'T FIX.