Synfig Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #96  -  Animated image path turns to absolute when it was relative
Posted Dec 17, 2012 - updated Jan 05, 2019
action_vote_minus_faded.png
1
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
    Not assigned to anyone
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Imported User
  • Owned by
    Not owned by anyone
  • Category
    Animation
  • Resolution
    RESOLVED
  • Priority
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Tags
    icon_customdatatype.png waypoints images
  • Difficulty
    icon_customdatatype.png Not determined
Issue description
genete:

  1. New empty document.
  2. Save it to a folder.
  3. Import an image file (File->Import). The filename parameter reflects the relative path from the saved sifz to the imported image file.
  4. Click the file name parameter and click the edit button. Select other image file. The file name path remains relative (good)
  5. Switch to animate mode.
  6. Repeat step 4. The result file name becomes absolute (bad).
Steps to reproduce this issue
Nothing entered.

#5
Comment posted by
 Konstantin Dmitriev
Apr 12, 05:17
This issue should be fixed in the master branch - https://github.com/synfig/synfig/commit/c5850b8dffa4dfad3f8156582226df57510b564e

The fix will be delivered with 1.0 RC4. Please test.
#6
Comment posted by
 Konstantin Dmitriev
Apr 23, 16:41
Fixed in Synfig Studio 1.0 RC4 - http://www.synfig.org/cms/en/news/synfig-studio-10-release-candidate-4/