Synfig Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #722  -  An Image Layer created from Menu/Layer i'nt saved and can't be embed
Posted Dec 07, 2014 - updated Jan 05, 2019
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     djay
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     djay
  • Owned by
    Not owned by anyone
  • Time spent
    1 hour
  • Category
    Import
  • Resolution
    RESOLVED
  • Priority
    Not determined
  • Targetted for
    icon_milestones.png 1.0
  • Tags
    icon_customdatatype.png import, image
  • Difficulty
    icon_customdatatype.png Not determined
Issue description
An Image Layer created from Menu/Layer i'nt saved and can't be embed

--> File Widget Selection ... is missing (idem for sound layer ) ! (cell renderer value : widget filename)

Idem for automatic Image Layer created when using brush. ( Brush do nothing without image layer ) <-- Fixed by https://github.com/synfig/synfig/pull/152
Steps to reproduce this issue
  • New Project
  • Menu/Layer/New Layer/Other/Image Layer
  • Brush on it
  • Save and Close Project
  • Open Project


Warning is shown

Warning /home/*path*/PRojectName.sifz:<string>:46:Layer 'import' rejected value for parameter 'filename'

Image is missing

#3
Comment posted by
 djay
Dec 12, 09:03
I'm working on Image Layer created by Brush Tool

https://github.com/d-j-a-y/synfig/tree/djay_gtk3_brushfixes
#4
Comment posted by
 Konstantin Dmitriev
Dec 15, 15:40
Great! I have merged the fixes from https://github.com/synfig/synfig/pull/152

They work fine if the image layer is automatically created by brush tool (when painting on the empty canvas). But if we will create an empty image using "Menu/Layer/New Layer/Other/Image Layer", then the image isn't saved.
#6
Comment posted by
 djay
Dec 28, 12:43
Since issue#744 is fixed, i think it's save to close this one also.