Synfig Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #651  -  Changing length of keyframe spills waypoints into previous keyframe range.
Posted Jun 24, 2014 - updated Jan 05, 2019
action_vote_minus_faded.png
2
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     blackwarthog
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Rylander
  • Owned by
    Not owned by anyone
  • Category
    Not determined
  • Resolution
    RESOLVED
  • Priority
    Not determined
  • Targetted for
    icon_milestones.png 1.0
  • Tags
    icon_customdatatype.png Not determined
  • Difficulty
    icon_customdatatype.png Not determined
Issue description
When dragging a keyframe in the timeline the waypoints between this and the surrounding keyframes is either spaced further or closer apart, rubberbanding them in relation to current and prev./next keyframes.

When changing the length of keyframes in the Keyframes panel no rubberbanding occurs. Instead intermediate waypoints is moved in relation to the current keyframe. If the length is shortened the waypoints spills over into the range of the previous keyframe. If undoing this only the waypoints in the range of the current keyframe is returning to their previous position, the ones that has spilled into the previous keyframe range stays there.

Desired behavior when changing keyframe length in Keyframes panel would be rubberbanding the waypoints before the current keyframe and moving the following keyframes/waypoints in relation to current keyframe.

This bug makes it almost impossible to change pacing of a portion of the timeline while keeping the rest of the animation intact.

See this graphics for a visual presentation of this bug. changing keyframe lengthicon_open_new.png
Steps to reproduce this issue
  1. Create an object and add keyframes at 0, 25, 50, 75 and 100frames.
  2. add waypoints at every 5fr through the timeline.
  3. Change the length of the waypoint at 25f to 13fr.
  4. See waypoints spill into the 0f keyframe range.

#5
Comment posted by
 Konstantin Dmitriev
Oct 28, 08:53
The issue is resolved in morevnaproject/gtk3 branch - https://github.com/morevnaproject/synfig/commit/367a93a30c06e53cf074e12a2631ab3f07ed6b56