Synfig Issue Tracker
Please log in to bookmark issues
OPEN  Bug report #594  -  importing (png) with alpha sections not displaying properly
Posted Feb 27, 2014 - updated Jul 01, 2015
Issue details
  • Type of issue
    Bug report
  • Status
  • Assigned to
    Not assigned to anyone
  • Progress
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
  • Owned by
    Not owned by anyone
  • Category
    Artwork construction
  • Resolution
    Not determined
  • Priority
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Tags
    icon_customdatatype.png gamma
  • Difficulty
    icon_customdatatype.png Not determined
Issue description
Some (not all) images I import (especially complicated ones) with alpha sections are not importing properly... synfig is ignoring some alpha sections.

I tried to import as pgn and gimp format.. neither work.

Im on Ubuntu, synfig 64.0 also tried 64.1


Steps to reproduce this issue
This pic is an eg of the problem

(pls import it in synfig) and put a black rectangle behind it so you can see it clearly.

Also pls import into gimp or inkscape (also with black background) and zoom in on both... you will see the difference.

Comment posted by
Jun 24, 07:06
  • Original file
    This comment was attached:

  • Expected output (gimp)
    blue-star and black into gimp
    blue-star and black into gimpicon_open_new.png

  • Synfig (1.0) output
    blue star and black into synfig
    blue star and black into synfigicon_open_new.png
Comment posted by
Jul 01, 11:40
A file was uploaded. the project to create the png image maskicon_open_new.png
Comment posted by
Jul 01, 11:44
investigating i suspect something around preference/gamma/colors setting=2.2 "instead of" 1.0

In the following images, look at and compare the alpha smooth (or not) limits.

reference output : gimp compositionicon_open_new.png

synfig composition 2.2icon_open_new.png

synfig composition 1.0icon_open_new.png

BUT ! when exporting to png file , the result is the same, always like with gamma set to 2.2 related to :