Synfig Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #572  -  Unable to save to... I had to change the name
Posted Jan 31, 2014 - updated May 12, 2014
action_vote_minus_faded.png
3
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Fixed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Fixed
  • Assigned to
     Konstantin Dmitriev
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     hlf
  • Owned by
    Not owned by anyone
  • Time spent
    4 hours
  • Category
    Not determined
  • Resolution
    RESOLVED
  • Priority
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Tags
    icon_customdatatype.png Not determined
  • Difficulty
    icon_customdatatype.png Not determined
Issue description
Hello I'm working in Windows 7, in a Laptop with AMD Phenom P920 Quad-Core. I'm using synfig 0.64.1, but the problem also apears in recent Synfig versions (0.65). I have problems when I try to save a drawing in Synfig. It says that it's unable to do it. When I change the name of the file, then I can save it.

Something I noted is that, when I open a synfig file from the explorer of windows, the problem doesn't show. I can save the file, wtihout to rename it.

  • A message box apears: Save- error: "Unable to save to: xxx"
  • In the terminal windows that appears when synfig runs the mesage says: synfig(6472) PM error: synfig::save_canvas(): Unable to rename file to correct filename, errno=2
  • I save the file with different name. The file save, but when do anothe change in the drawing and save again, the same probem re - appears
Steps to reproduce this issue
  • I run Synfig from the Windows Menu
  • I begin to draw something in the deafult open file:"Synfig Animation !
  • I save the file with other name in a personal carpet
  • I make some changes to the drawing, just moving some points
  • I do a click in the save button of the tools panel
  • A message box apears: Save- error: "Unable to save to: xxx"



#2
Comment posted by
 Stephen P.
Mar 02, 19:01
Affects me too, just as described.
#4
Comment posted by
 PaterRik
Mar 26, 09:33
Same problem here. I reinstalled still the same problem. I am using the 64-bit version (0.64.1). I also get multiple error messages when working, see attached picture.

Patrik

synfig erroricon_open_new.png
#7
Comment posted by
 Konstantin Dmitriev
Apr 27, 06:44
While trying to fix the problem, I have found one workaround - if you run Synfig Studio with Administrator privileges, then the problem doesn't happen.
#8
Comment posted by
 Konstantin Dmitriev
May 11, 12:03
Looks like I've found where the problem comes from. For now you can try the following workaround: edit the Synfig Studio shortcut and change its working directory to "%HOMEDRIVE%%HOMEPATH%" (without quotes). Then you can run Synfig Studio (and save files) using this shortcut without admin privileges.
#9
Comment posted by
 Konstantin Dmitriev
May 12, 11:52
The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from Confirmed to Fixed.
  • This issue's progression has been updated to 100 percent completed.
  • The resolution has been updated, from Not determined to RESOLVED.
  • Time spent on this issue, from No time spent to 4 hours.
  • Information about the user working on this issue has been changed, from Konstantin Dmitriev to Not being worked on.
#10
Comment posted by
 Konstantin Dmitriev
May 12, 11:54
The issue is fixed now.

For users of 0.64.1 version I have made special builds: