Synfig Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #564  -  Multiple bones link not symmetrical
Posted Jan 28, 2014 - updated Jan 05, 2019
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Fixed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Fixed
  • Assigned to
     blackwarthog
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Carlos López
  • Owned by
    Not owned by anyone
  • Time spent
    12 days
  • Category
    Animation
  • Resolution
    RESOLVED
  • Priority
    Must fix before next release
  • Targetted for
    icon_milestones.png 1.0
  • Tags
    icon_customdatatype.png symmetrical bones
  • Difficulty
    icon_customdatatype.png Not determined
Issue description
I've found that when you link two symmetrical points to multiple bones with the same linking weight, the behavior is not symmetrical when it should be.

See http://www.synfig.org/forums/viewtopic.php?f=34&t=4816&p=21778#p21684 for more details.

Using commit ID: 83963e49d4904c98c99b95f70e24a4f465e21c4d
Steps to reproduce this issue
Nothing entered.

#3
Comment posted by
 blackwarthog
Feb 05, 16:08
Bug appears when origin of spline was moved (not zero)
#4
Comment posted by
 blackwarthog
Feb 05, 17:01
Oops... It's not reason. I understand problem.
#5
Comment posted by
 Konstantin Dmitriev
Mar 26, 08:59
This is fixed now - https://github.com/synfig/synfig/pull/112 New "Link to Skeleton" action uses Weighted Average convert type to link vertex to multiple bones.

The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from New to Fixed.
  • This issue's progression has been updated to 100 percent completed.
  • The resolution has been updated, from Not determined to RESOLVED.
  • Time spent on this issue, from No time spent to 12 days.
  • Information about the user working on this issue has been changed, from blackwarthog to Not being worked on.