Synfig Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #557  -  Hide "Outline" from UI
Posted Jan 22, 2014 - updated Jan 22, 2014
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Not a bug" and resolution "WON'T FIX".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Not a bug
  • Assigned to
    Not assigned to anyone
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Yu Chen
  • Owned by
    Not owned by anyone
  • Category
    User interface
  • Resolution
    WON'T FIX
  • Priority
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Tags
    icon_customdatatype.png Not determined
  • Difficulty
    icon_customdatatype.png Not determined
Issue description
Since Advanced Outline Layer has implemented all features of Outline Layer, and we encourage user to use Advanced Layer instead of Outline Layer, we can just hide it from UI. There are three UI elements we can consider to remove:
  1. "Make Outline" option in Right-Click Menu of Layer Panel
  2. "Create Outline" option in Tool Options Panel
  3. "New Layer->Geometry->Outline Layer" in Layers menu.


And of course, we still need to keep the code to make sure we can open these file including Outline Layer/s created in previous version of Synfig Studio.
Steps to reproduce this issue
Nothing entered.

#2
Comment posted by
 Carlos López
Jan 22, 09:56
Please no.

Advanced Outlines are so cool but when the number of splinepoints or width points increases the performance goes down. That's something that happens due to the need to place width points aligned with the spline length that needs to be calculated on each frame and that's a hight computational cost there. Surely it can be optimized but I think that we should keep the usage of normal Outlines for most of the people who doesn't care on variable width with free alignment along the spline path (and that happens many times).

For the same reason, rectangles should be removed because you can create a polygon instead, or even polygons should be removed since they can be created using regions... Same thing would happen with circles, etc.
#3
Comment posted by
 Konstantin Dmitriev
Jan 22, 10:39
I absolutely agree with Carlos.

According to my practical experience, Advanced Outlines is not a substitution for Regular Outline. There are cases when it's better to have widthpoints linked to the vertex position and sometimes it's better to have them independent.