Synfig Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #476  -  Dev Version creating badly formed XML in .sifs
Posted Aug 29, 2013 - updated Apr 30, 2015
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
    Not assigned to anyone
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     DaveJ
  • Owned by
    Not owned by anyone
  • Category
    Not determined
  • Resolution
    RESOLVED
  • Priority
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Tags
    icon_customdatatype.png Not determined
  • Difficulty
    icon_customdatatype.png Not determined
Issue description
Synfig Studio is regularly giving "Document Not Well Formed Errors" - both on using plugins and when trying to open files recovered from crashes.

Development version: Revision: 20130826 Branch: master Revision ID: 034175

Built on Aug 26 2013

Built with: ETL 0.04.16 Synfig API (006000) Synfig library 47 GTK+ 2.16.6 GNU G++ 4.1.2

Using: Synfig 0.64.0 GTK+ 2.24.19

Installed using the RPM on Fedora 19 KDE.

The error output in the Konsole is below.

~$ synfigstudio

   synfig studio -- starting up application...


synfig(2307) 16:05:59 info: Loading modules from /opt/synfig/etc/synfig_modules.cfg synfig(2307) 16:05:59 info: Loading plugins from /opt/synfig/share/synfig/plugins synfig(2307) 16:05:59 info: Loading plugin: add-skeleton-simple synfig(2307) 16:05:59 info: Loading plugin: view-unhide-all-layers synfig(2307) 16:05:59 info: Loading plugins from /home/kecskebak/.synfig/plugins

(synfigstudio:2307): GLib-GObject-WARNING **: attempting to add an interface (Gtk Tree Model) to class (gtkmm__CustomObject_KeyframeTreeStore) after class_init

(synfigstudio:2307): GLib-GObject-WARNING **: attempting to add an interface (Gtk Tree Drag Source) to class (gtkmm__CustomObject_KeyframeTreeStore) after class_init

(synfigstudio:2307): GLib-GObject-WARNING **: attempting to add an interface (Gtk Tree Drag Dest) to class (gtkmm__CustomObject_KeyframeTreeStore) after class_init

(synfigstudio:2307): GLib-GObject-WARNING **: attempting to add an interface (Gtk Cell Editable) to class (gtkmm__CustomObject_N6studio15ValueBase_EntryE) after class_init

(synfigstudio:2307): GLib-GObject-CRITICAL **: Object class gtkmm__CustomObject_N6studio15ValueBase_EntryE doesn't implement property 'editing-canceled' from interface 'Gtk Cell Editable' synfig(2307) 16:06:25 error: Keyframe Action Manager::refresh(): Not ready! synfig(2307) 16:06:26 error: Keyframe Action Manager::refresh(): Not ready! synfig(2307) 16:06:26 info: Python 3 binary found: python3

(synfigstudio:2307): Gtk-CRITICAL **: IA__gtk_widget_get_window: assertion `GTK_IS_WIDGET (widget)' failed

(synfigstudio:2307): Gdk-CRITICAL **: IA__gdk_window_get_composited: assertion `GDK_IS_WINDOW (window)' failed

(synfigstudio:2307): Gtk-CRITICAL **: IA__gtk_widget_get_window: assertion `GTK_IS_WIDGET (widget)' failed

(synfigstudio:2307): Gdk-CRITICAL **: IA__gdk_window_get_composited: assertion `GDK_IS_WINDOW (window)' failed I/O error : Is a directory ./:1: parser error : Document is empty

^ ./:1: parser error : Start tag expected, '<' not found

^ synfig(2307) 16:06:26 error: Standard Exception: Document not well-formed.
Steps to reproduce this issue
1. Open Synfig Studio 2. Draw two stars on the canvas 3. Hide both star layers 4. Run plugin "Unhide All Layers"

Expected Result: Star layers unhidden

Result Error dialog: "Document Not Well Formed" Synfig crashes

#2
Comment posted by
 DaveJ
Aug 31, 12:22
Looking at this more, the issue goes away if Python 3 is installed. The cause of the problem seems to be the Synfig RPM file does not list Python 3 as one of its dependencies and Synfig Studio does not "grey out" the plug-ins menu option if no suitable version of Python is found, so this really isn't a bug with Synfig, just a packaging issue.
#3
Comment posted by
 Konstantin Dmitriev
icon_reply.pngSep 02, 15:38, in reply to comment #2


I prefer to have Plugins menu always available and check for Python 3 existence right at the time when plugin invoked (yhis is how it is now).

Talking about issue itself, it is not really related with Python 3. The issue is fixed by Carlos in the latest master branch - https://github.com/synfig/synfig/commit/1c6c0b3e5b0fc8f4347bd6b7467973fc589b8cc7

#4
Comment posted by
 Carlos López
Dec 18, 11:53
IS the issue fixed in 0.64.1?
#7
Comment posted by
 NormanPowell
May 16, 06:44
Here the coding help is quite useful for the public and they can also understand the bugs as well. Your sharing articles are quite recommended and the people should get benefit through. I admire your tremendous sharing do share on https://spacecoastdaily.com/2022/03/top-3-genius-essay-writing-services-for-students/ always such helping material continue sharing.