Synfig Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #450  -  Cairo: Artifacts for stretch layer in combination with rotate layer
Posted May 27, 2013 - updated Jan 05, 2019
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
     Carlos López
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Konstantin Dmitriev
  • Owned by
    Not owned by anyone
  • Time spent
    12 weeks, 4 days, 6 hours
  • Category
    Rendering
  • Resolution
    RESOLVED
  • Priority
    Not determined
  • Targetted for
    icon_milestones.png 0.64.1
  • Tags
    icon_customdatatype.png cairo
  • Difficulty
    icon_customdatatype.png Not determined
Issue description
When I apply stretch layer on top of rotate layer I get distorted image in Cairo renderer.

See attached samples.
Steps to reproduce this issue
Nothing entered.

#2
Comment posted by
 Konstantin Dmitriev
May 27, 10:30
A file was uploaded. 3325-2-bug.zipicon_open_new.png This comment was attached:

Sample file
#3
Comment posted by
 Konstantin Dmitriev
May 27, 10:32
A file was uploaded. Original image displayed with software renderer.icon_open_new.png
#4
Comment posted by
 Konstantin Dmitriev
May 27, 10:33
A file was uploaded. Same image displayed with cairo renderericon_open_new.png This comment was attached:

Notice the artifacts appear randomly on top of the image. Also, you can see the angle of the head rotation is different.
#6
Comment posted by
 Carlos López
May 27, 11:46
I've tested the same combination of layers over a simple region and it happens the same, so it is not related to import image.

Render artifact doesn't happen on Navigator, Preview or export to png but in all cases, rotation is wrong (seems that the Stretch layer is ignored). It might explain the render artifact on tile render since each tile ignores the stretch individually and so the tiles are broken when they are individually rotated.

Also, I've noticed that the Navigator in Cairo mode doesn't clear the surface between render so it stacks all the renders one on top of other.
#8
Comment posted by
 Carlos López
Aug 14, 14:25
The bug fix is 100% complete. It will be closed once 0.64.1 is released and it works in all platforms
#10
Comment posted by
 Carlos López
Aug 23, 17:41
Applied to master branch

The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from New to Closed.
  • The resolution has been updated, from Not determined to WON'T FIX.
  • Information about the user working on this issue has been changed, from Carlos López to Not being worked on.
  • Time spent on this issue, from No time spent to 12 weeks, 4 days, 6 hours.