Synfig Issue Tracker
Please log in to bookmark issues
CLOSED  Bug report #427  -  Build error: 'RELEASE_VERSION_0_63_06' was not declared
Posted May 02, 2013 - updated May 02, 2013
icon_info.png This issue has been closed with status "Fixed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
  • Assigned to
     Carlos López
  • Progress
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Yu Chen
  • Owned by
    Not owned by anyone
  • Time spent
    1 hour
  • Category
    Compiling / Packaging
  • Resolution
  • Priority
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Tags
    icon_customdatatype.png Not determined
  • Difficulty
    icon_customdatatype.png Not determined
Issue description
When building latest code(commit 45699fb96c5eb973c3c02ccb5d9542bad53ab379) on mac, there is an error as shown below:

But in fact, there is no 06306 existed, so by adding "RELEASE_VERSION_0_63_06" to releases.h is not the right/proper way to fix it, isn't it? message start....... opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/cairo -I/opt/local/include/pixman-1 -I/opt/local/include/freetype2 -I/opt/local/include/libpng15 -I/opt/local/include/harfbuzz -I/Users/chenyu/Source/synfig/install/include -I/opt/local/include/sigc++-2.0 -I/opt/local/lib/sigc++-2.0/include -DSYNFIG_NO_DEPRECATED -DLOCALEDIR=\"/Users/chenyu/Source/synfig/install/share/locale\" -DLIBDIR=\"/Users/chenyu/Source/synfig/install/lib\" -DSYSCONFDIR=\"/Users/chenyu/Source/synfig/install/etc\" -D_DEBUG -g -O0 -W -Wall -MT libsynfig_la-waypoint.lo -MD -MP -MF .deps/libsynfig_la-waypoint.Tpo -c waypoint.cpp -fno-common -DPIC -o .libs/libsynfig_la-waypoint.o valuenode.cpp: In static member function 'static bool synfig::ValueNode::subsys_init()': valuenode.cpp:180: error: 'RELEASE_VERSION_0_63_06' was not declared in this scope make2: *** libsynfig_la-valuenode.lo Error 1 make2: *** Waiting for unfinished jobs.... mv -f .deps/libsynfig_la-waypoint.Tpo .deps/libsynfig_la-waypoint.Plo make1: *** install-recursive Error 1 make: *** install-recursive Error 1 message end...............

cyosx:synfig chenyu$ git diff releases.h diff --git a/synfig-core/src/synfig/releases.h b/synfig-core/src/synfig/releases.h index 792d58f..f8b6efa 100644 --- a/synfig-core/src/synfig/releases.h +++ b/synfig-core/src/synfig/releases.h @@ -49,6 +49,7 @@ namespace synfig {

cyosx:synfig chenyu$
Steps to reproduce this issue
Nothing entered.

Comment posted by
 Yu Chen
May 02, 04:56
Confirmed by Konstantin:

Yes, the RELEASE_VERSION_0_63_06 should be replaced to RELEASE_VERSION_0_64_0 everywhere in the source tree. K.

And fixed in my branch now. The pull req will send soon.
Comment posted by
 Carlos López
May 02, 04:57
Fixed in latest master branch

The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from Being worked on to Fixed.
  • This issue's progression has been updated to 100 percent completed.
  • The resolution has been updated, from Not determined to RESOLVED.
  • Information about the user working on this issue has been changed, from Carlos López to Not being worked on.
  • Time spent on this issue, from No time spent to 1 hour.