Synfig Issue Tracker
star_faded.png
Please log in to bookmark issues
bug_report_small.png
CLOSED  Bug report #262  -  Image Layer: Animated filename parameter not processed during "Save As" operation
Posted Dec 25, 2012 - updated Jan 05, 2019
action_vote_minus_faded.png
1
Votes
action_vote_plus_faded.png
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
     
    Closed
  • Assigned to
    Not assigned to anyone
  • Progress
       
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
     Imported User
  • Owned by
    Not owned by anyone
  • Category
    Not determined
  • Resolution
    RESOLVED
  • Priority
    Not determined
  • Targetted for
    icon_milestones.png Not determined
  • Tags
    icon_customdatatype.png Not determined
  • Difficulty
    icon_customdatatype.png Not determined
Issue description
Konstantin Dmitriev:

Usually, if you open Synfig file, containing images, and using "Save as" to save it into another place, then all image paths are transformed to correctly point to the new location.

But if you animate Filename parameter of the image layer, then during "Save as" operation the paths are not transformed and you loose your image data.
Steps to reproduce this issue
  1. Download attached file - 39-sample.zip and unpack it
  2. Open 39-ivan-and-morevna.sif in Synfig Studio
  3. Chose "File -> Save As" and save file to _another_ location
  4. Close file and reopen the file you just saved - All images are lost.

#2
Comment posted by
 Imported User
Dec 25, 06:18
A file was uploaded. 39-sample.zipicon_open_new.png
#3
Comment posted by
 Imported User
Dec 25, 06:18
Carlos López González:

I've been looking to this request and I don't find any way to solve this easily. The magic that happens when you save a composition with a non animated filename that it is converted to the relative path is due to the fact that the relative and the absolute path are stored in the layer at the time of the filename is set. That allows later to always obtain a relative path when the parameter is retrieved (you know the absolute path of the file source as well as the relative) and so, save it as relative. But when the parameter is animated, only the relative value is stored on the waypoints. With the relative values only is not possible to know what's the new path for each animated filename value because, even knowing your absolute destiny path, you don't know the absolute path for each animated filename value, so it is not possible to convert to relative when saving.

It could be possible to save as absolute when animated to eliminate that problem (when you move the document only and not the file sources) but it would create the problem of the mobility of the whole project to another location (because the paths are not relative, you have to keep the structure on any computer that want to read the document) what is a real regression in my opinion.

So I don't know how solve this bug with a simple solution.
 
#6
Comment posted by
 Konstantin Dmitriev
Apr 23, 16:42
Fixed in Synfig Studio 1.0 RC4 - http://www.synfig.org/cms/en/news/synfig-studio-10-release-candidate-4/